Degraded availability email provider
Incident Report for Betty Blocks
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 08, 2019 - 09:08 CET
Monitoring
Our email provider is having connectivity issues. This can result in a delay when sending or receiving emails
in the Betty Blocks platform. When more information is available this page will be updated.
Posted 5 months ago. Feb 05, 2019 - 18:05 CET
This incident affected: Platform services (Betty Blocks cloud, My Betty Blocks portal).