Degraded performance
Incident Report for Betty Blocks
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 29, 2019 - 13:04 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Mar 29, 2019 - 12:29 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Mar 29, 2019 - 12:06 CET
Update
We are continuing to investigate this issue. The next update will be given within 15 minutes.
Posted 3 months ago. Mar 29, 2019 - 11:50 CET
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 29, 2019 - 11:19 CET
This incident affected: Betty Blocks application platform.