Betty Blocks assets failing to load on all US region zones (us2, ca4 and private zones 10, 13 and 17)

Incident Report for Betty Blocks

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 19:48 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 18:15 CEST

Identified

We have identified the issue and our team is working on a fix.
Posted Aug 18, 2025 - 17:35 CEST

Investigating

We are currently experiencing issues with uploaded files and public files. Some files may not load or be accessible.
Posted Aug 18, 2025 - 17:30 CEST
This incident affected: Betty Blocks private cloud zone 10 (IDE), Betty Blocks private cloud zone 13 (IDE), Betty Blocks private cloud zone 17 (IDE), Betty Blocks zone US2 (IDE), and Betty Blocks zone CA4 (IDE).