Resolved: Degraded performance on NL6

Incident Report for Betty Blocks

Resolved

Hi,

We are writing to inform you that the period of degraded performance on our platform has now been fully resolved.

Earlier, you may have experienced slower loading times, occasional delays in processing, or intermittent responsiveness due to an issue with queuing expressions. A fix has been implemented, and system performance has returned to normal across all services.

The following zone and component were affected:

Affected Zone:
NL6

Affected Component:
Expressions - Users may have experienced delays or degraded performance with queued expressions.

We understand that any performance degradation can impact your workflow, and we sincerely apologize for any inconvenience this issue may have caused.

No further action is required on your end. If you continue to experience any residual issues, please do not hesitate to contact our support team.
Posted Sep 09, 2026 - 02:00 CEST