Reduced availability on UI Builder
Incident Report for Betty Blocks
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 01, 2019 - 20:53 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 20 days ago. Oct 01, 2019 - 20:52 CEST
Investigating
We are currently investigating this issue
Posted 20 days ago. Oct 01, 2019 - 20:32 CEST
This incident affected: Betty Blocks application platform.