Degraded availability for My Betty Blocks
Incident Report for Betty Blocks
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 09:47 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2021 - 09:36 CEST
Investigating
We are currently investigating this issue.
Posted Sep 08, 2021 - 09:03 CEST
This incident affected: Betty Blocks global services (My Betty Blocks portal).