Degraded performance on NL1

Incident Report for Betty Blocks

Resolved

We are happy to inform you that the performance issues on the NL1 zone have been fully resolved. Our team has implemented the necessary fixes, and you should now be experiencing normal performance across all zones and components.

Thank you for your patience and understanding during this period. We appreciate your support.

If you continue to experience any performance issues, please do not hesitate to contact our support team via Intercom.
Posted Nov 25, 2025 - 14:20 CET

Investigating

We are writing to inform you about a temporary period of degraded performance which you may have experienced on our platform. Our team is aware of this issue and has taken immediate action to resolve this as soon as we could.

During this time, you may have experienced slower loading times, occasional delays in processing, or intermittent responsiveness in certain areas of the platform.

The following zones and components were affected:

Affected Zones:

- NL1

Affected Components:

Classic Endpoints & Classic Backoffice records:
Users are having trouble uploading or retrieving files or assets from their applications.

We understand that degraded performance can be frustrating, and we apologise for any inconvenience this may have caused to your workflow.

Thank you for your patience and understanding.
Posted Nov 25, 2025 - 14:02 CET
This incident affected: Betty Blocks zone NL1 (Classic Endpoints, Classic Backoffice).