Degraded performance on West Europe zones
Incident Report for Betty Blocks
Resolved
Along with Microsoft, we are no longer experiencing degraded performance caused by this issue. The issue has been resolved.
Posted Jul 06, 2023 - 11:15 CEST
Update
Microsoft has repaired the impacted links, restoring networking capacity between datacenters. Many internal and external services saw signs of recovery, but they continued to work on mitigating some latency issues.

Microsoft will continue to monitor the network infrastructure and capacity, and will continue to augment the region with additional capacity to de-risk the impact of any future issues like fiber cuts.
Posted Jul 06, 2023 - 08:34 CEST
Monitoring
Due to severe weather conditions in the Netherlands, Microsoft has encountered a fiber cut that has caused a disruption in the connectivity between two datacenters in the West Europe region. As a result, services that depend on internal communications with other services, may experience degraded performance. Microsoft is continuing applying mitigation actions and monitoring the status of this issue.
Posted Jul 05, 2023 - 16:18 CEST
Update
Microsoft is currently extending the investigation and applying mitigation actions while monitoring the status, to confirm if this resolves the issue.
Posted Jul 05, 2023 - 14:41 CEST
Identified
We are currently experiencing degraded performance on multiple zones. The cause of this issue is known and lies within Azure. You may experience “Gateway timeout” or “This website is under heavy load” errors. Microsoft is working on collaborating with relevant teams to identify mitigation options.
Posted Jul 05, 2023 - 11:46 CEST
This incident affected: Betty Blocks zone NL3 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks private cloud zone 3 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, ActionsAPI), Betty Blocks private cloud zone 6 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks private cloud zone 7 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks zone NL4 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks private cloud zone 9 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks private cloud zone 11 (API, Application logging, Classic Background Actions, Classic Backoffice, Classic Endpoints, IDE, Pages, DataAPI, ActionsAPI), Betty Blocks zone NL6 (API, Application logging, Classic Background Actions, Classic Endpoints, Classic Backoffice, Pages, DataAPI, ActionsAPI, IDE), and IDE, Pages, DataAPI, ActionsAPI.