We are happy to inform you that the performance issues have now been fully resolved. Our team has implemented the necessary fixes, and you should now be experiencing normal performance across all zones and components.
Thank you for your patience and understanding during this period. We appreciate your support.
If you continue to experience any performance issues, please do not hesitate to contact our support team via Intercom. Kind regards,
The Support Team
Posted Jan 09, 2026 - 16:15 CET
Investigating
We are writing to inform you about a temporary period of degraded performance you may currently be experiencing on our platform. Our team is aware of this issue and is actively working to identify and resolve it as quickly as possible.
During this time, you may experience slower loading times, occasional delays in processing, or intermittent responsiveness in certain areas of the platform.
The following zones and components are currently affected:
Affected Zones: - NL6
Affected Components: [Actions-runtime]: (processing actions) - You may encounter errors, or actions that are not working as expected.
We understand that degraded performance can be frustrating, and w apologize for any inconvenience this may cause to your workflow. Our engineers are working diligently to pinpoint the root cause and implement the necessary fixes.
We will provide updates on our progress and, if possible, give an estimated time to resolution as they become available. Thank you for your patience and understanding as we work to restore full performance.
Kind regards,
The Support Team
Posted Jan 09, 2026 - 16:01 CET
This incident affected: Betty Blocks zone NL6 (ActionsAPI).