Degraded performance on several zones
Incident Report for Betty Blocks
Resolved
We experienced an issue with degraded performance on the following zones: NL3, NL4 and Private zone 3. A fix has been implemented, and we confirm this incident has been resolved.
Posted Mar 08, 2023 - 13:24 CET
Monitoring
Azure Engineers moved the impacted database servers to a different healthy environment, and we are currently monitoring the situation.
Posted Mar 08, 2023 - 09:54 CET
Update
Update: We would like to update you on the ongoing issue that we have been experiencing.

We and our partner Microsoft are continuing our investigation into the issue and unfortunately, we do not have a clear timeline for when the issue will be resolved. We understand that this may be causing inconvenience and we want to assure you that we are doing everything we can to resolve this as quickly as possible.

When we have more information, we will post an update here. Thank you for your patience and understanding during this time.
Posted Mar 08, 2023 - 00:48 CET
Update
Our investigation into the ongoing issue is still ongoing.

We have received acknowledgement from Microsoft about the trouble we’ve been experiencing and their product group is now involved in investigating the issue with us. We appreciate their assistance in resolving this issue as quickly as possible.

We will be posting a new update on the situation at 23:00 CEST, so please stay tuned for further details. We understand that this situation is causing inconvenience and we appreciate your patience as we work towards a resolution.
Posted Mar 07, 2023 - 21:04 CET
Update
We want to keep you informed about the ongoing investigation into the degraded performance issue we’re currently experiencing. We recently had a call with Microsoft to help determine the root cause of the problem, but unfortunately, we have not yet been able to identify it.

Both our teams are working tirelessly to investigate and resolve the issue. We apologize for any inconvenience this may be causing and appreciate your patience while we work to restore normal service as soon as possible.

We will provide another update around 21:00 CEST.

Thank you for your understanding.
Posted Mar 07, 2023 - 19:08 CET
Update
The cause of this issue is still being investigated together with our hosting provider Microsoft. Unfortunately, until now, no further cause has been found. We will provide an update about the situation around 19:00 CEST.
Posted Mar 07, 2023 - 16:51 CET
Update
We are currently still investigating the cause of this issue together with our hosting provider Microsoft. Unfortunately, until now, no further cause has been found. We will provide an update about the situation around 17:00 CEST.
Posted Mar 07, 2023 - 15:10 CET
Update
Currently, we're investigating the cause of this issue together with our hosting provider, Microsoft. We will provide an update about the situation around 15:00 CEST.
Posted Mar 07, 2023 - 13:55 CET
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 11:35 CET
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 11:07 CET
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 10:57 CET
Investigating
Currently, several zones are experiencing degraded performance. We are investigating the cause of this issue.
Posted Mar 07, 2023 - 10:42 CET
This incident affected: Betty Blocks zone NL3 (Classic Background Actions, Classic Backoffice, Pages), Betty Blocks private cloud zone 3 (Classic Background Actions, Classic Endpoints, Classic Backoffice), and Betty Blocks zone NL4 (Classic Background Actions, Classic Backoffice, Pages).